0 votes

enter image description here

asked in Solved by (120 points)
recategorized by

1 Answer

0 votes

Unfortunately, we were forced by Apple platform (due to compilers) and Qt (because of upgrades) to upgrade our dev tools and build machines to 10.12 versions. And unfortunately, this means that application needs to run on 10.12+ versions.

The previous version of dev tools contained the critical bug which caused random crashes and the only way was to upgrade to Qt 5.9.

In compare to Windows, where we can compile on latest Windows10 and still were able to support also WindowsXP, OSX/Linux has the design that it's necessary to compile on the oldest supported version.

This means to keep up to date old Linux and OSX versions and sometimes when there is critical bug this means we have to update to higher version.

We're sorry for this but are not able to solve it in any way. This upgrade affects only a few users because most users in OS X ecosystem keep our systems updated.

answered by Skipper developer (131k points)

Thank you for info! Fixed.

Seriously :-)

Also, change the image... I have taken a screenshot as expected you changed the website.

enter image description here

Yes, I wrote you that I fixed the page. It was old information which we missed to update.

Also, Is it software industry practice to drop support for so many version overnight???

As of yesterday, you have supported
Version 10.6: "Snow Leopard"

As of today, you dropped support for
Version 10.6: "Snow Leopard"
Version 10.7: "Lion"
Version 10.8: "Mountain Lion"
Version 10.9: "Mavericks"
Version 10.10: "Yosemite"
Version 10.11: "El Capitan"

I tried to explain you that it's not overnight. It was continuous upgrades but we missed to update the page. Of course this is not over-night upgrade

Thank you for info about logo. It's fixed now too.